« Found Type Friday #39 | Main | Any questions? »

Comments

Rob Sawkins

MeNeither! Thanks for letting us know ;-)

Hugo

I'd heard of intercapping, but not camel case. I prefer the latter!

When programming it's better for readability to have descriptive names for variables like KMaxTInt, dataChanged, iRotateClockwise rather than just x or int or c.

There are often coding conventions for these, like for C++ with Symbian, constants begin with a capital K (KMaxTInt); member variables (that persist for long term use) begin with a lower case i (for instance) (iRotateClockwise); and automatic variables (used in the short term) begin with a lower case letter (dataChanged).

A similar thing happens for class and function names, these begin with a capital letter (IsImageMarked).

So when a software engineer has to think up a name, chances are they'll take two words and smash them together.

I think camel case is over-used nowadays for tech things, and it results in people getting it wrong lots. So many times I've seen names that don't use intercapping written with a capital in the middle. Also, but less often, you see people write a name that's two words as one, but with capitals. (And how hard is it to check?!)

Is it Typepad or TypePad? LifeBlog or Lifblog? LiveJournal or Livejournal? SixApart or Six Apart? Bloglines or BlogLines? FaceBook or Facebook?

Let's just stick to proper names!

Richard

Thanks Hugo; excellent comment and insight into the weird world of the programmer. As weird as the weird world of the graphic designer.

Jeremy

I love CamelCase, but never knew the "official" term.

I have found it to be a useful alternative when the company or product name is common but you are trying to distinguish it in print or building the brand.

I love your site by the way. Great Stuff.

David

ThanksForTheLesson!

iAgreeWithJeremy:LoveYourSite.

James Stevenson

Hugo is right about the prevalence of camel case in programming. It gets used in a lot of mainstream languages-- Java, C, C++, C#, etc. There is another method, though, which I've heard people call "snake case" and "dash case" (though I don't think these are authoritative) which some other (*ahem, smarter) languages like Ruby use. Here, spaces are replaced by the underscore character:

e.g. rotate_clockwise or set_data_handler

This coding convention was created specifically to address the readability problems with camel case. Of course, from a typographical perspective, it's probably not as useful.

The comments to this entry are closed.